Etrange bug

Voir le sujet précédent Voir le sujet suivant Aller en bas

Etrange bug

Message par Elector le Sam 15 Mar 2008 - 4:13

Bonjour, quand je start une game avec stargate (le tuto en création compris) je recoit toujours ce message d'erreur:

Sat Mar 15 21:11:01 2008
Loaded Archive: 'Homeworld2.big'
UTIL -- filepath failure, path doesn't exists 'C:\Program Files\Sierra\HOMEWO~1\data\locale\english'
Loaded Archive: 'english.big'
Uing ..profiles\ for profiles folder
GAME -- Using player profile Guillaume
Changing from a 32 bit colour depth in winNT (5.1 build 2600), Service Pack 2
Using NVIDIA Corporation's 2.1.1 GeForce 7300 GS/PCI/SSE2/3DNOW! renderer (Suspected driver is nvoglnt.dll 6.14.11.6267)
Loaded Archive: 'englishSpeech.big'
Loaded Archive: 'Music.big'
SOUND -- created destination [ fdaudio ], handle [ 4 ] with [ 48 ] channels created
SOUND -- created destination [ fda streamer ], handle [ 5 ] with [ 8 ] channels created
Build name: The Dust Wars - AutoBuild3569 - Ordered by smmatte
Built by : mrbuild
Data path : C:\Program Files\Sierra\HOMEWO~1\data
Resetting fp control word.
CmdLine: -overrideBigFile
Starting Level: Data:\LevelData\Campaign\tutorial\m01\m01.level
EngineTrailStatic::getTweaks requesing index(2) that doesn't exist.
EngineTrailStatic::getTweaks requesing index(2) that doesn't exist.
EngineTrailStatic::getTweaks requesing index(2) that doesn't exist.

Elector
Dévelopeur
Dévelopeur

Nombre de messages : 232
Age : 24
Humeur : Pas de vos affaires!!
Date d'inscription : 27/01/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par piper le Sam 15 Mar 2008 - 4:17

les tutorials et les missions ne marchent pas avec le mod..

_________________
Piper

piper
Admin
Admin

Nombre de messages : 705
Age : 22
Humeur : Négative envers seut qui regarde ma fiche
Date d'inscription : 01/09/2007

Voir le profil de l'utilisateur http://spaceconflict.freeforumfree.com

Revenir en haut Aller en bas

Re: Etrange bug

Message par Elector le Sam 15 Mar 2008 - 4:28

je sait... j'ai entrepris de le modifier. En faite tout marche sauf ce que j'ai mis comme bug

Elector
Dévelopeur
Dévelopeur

Nombre de messages : 232
Age : 24
Humeur : Pas de vos affaires!!
Date d'inscription : 27/01/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par LeSunTzu le Sam 15 Mar 2008 - 12:37

Ce qui est dans ton error log ne fait pas crasher le jeu. C'est simplement un modèle où des trainées sont prévues dans le fichier ship mais où il manque les joints dans le hod. Si tu n'as rien de plus, c'est probablement une erreur de type hod manquant ou le fichier campaign qui est erroné

LeSunTzu
Dévelopeur
Dévelopeur

Nombre de messages : 149
Date d'inscription : 04/11/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par Sajuuk le Sam 15 Mar 2008 - 13:48

donne tout le hw2.log, il te manque des lignes!

_________________
{Mes Vidéos} Config Pc:
Cpu : Amd Athlon 64 X2 4800+ Dual Core 2,50 GHz Cache L1 256 Ko L2 1 Mo Bus HT 2000 MHz
Ram : Corsair 3 Go XMS2 DDR2 800 MHz Pc 6400 (2x 512 Mo + 2x 1 Go)
Cg : Albatron nVidia GeForce 8600Gt Ram 512 Mo 400 MHz DDRII Gpu 540 MHz 128 Bits Shaders 1200 MHz - Pci-E

Sajuuk
Dévelopeur
Dévelopeur

Nombre de messages : 1479
Age : 21
Humeur : En forme!
Date d'inscription : 01/09/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par Elector le Sam 15 Mar 2008 - 18:42

Non il ne me manque aucune ligne... c'est bien ça le Hw2.log...

en fait il n'y a que le terriens qui ont l'air de bugger...

Elector
Dévelopeur
Dévelopeur

Nombre de messages : 232
Age : 24
Humeur : Pas de vos affaires!!
Date d'inscription : 27/01/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par Adimo le Sam 15 Mar 2008 - 21:54

Quelle carte ?

_________________
Configuration Pc :
Processeur : AMD Athlon 64 3000+
Mémoire : Corsair 2 Go DDR 400MHz Pc 3200 (4x 512 Mo)
Carte Graphique : Msi nVidia GeForce Nx6600GT 128Mo AGP 8x (2)
Carte Mère : Gigabyte K8 Triton (nForce3)
Disque Dur : 40Go DD IDE ; 80Go DD IDE ; 320Go DD IDE (ultra ATA/133 tous)

Adimo
WebMaster
WebMaster

Nombre de messages : 489
Age : 24
Humeur : Bonne
Date d'inscription : 01/09/2007

Voir le profil de l'utilisateur http://adimeau.free.fr/

Revenir en haut Aller en bas

Re: Etrange bug

Message par Elector le Sam 15 Mar 2008 - 23:04

On dirait que c'est seulement durant mon tutoriel scratch

Elector
Dévelopeur
Dévelopeur

Nombre de messages : 232
Age : 24
Humeur : Pas de vos affaires!!
Date d'inscription : 27/01/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par Sajuuk le Dim 16 Mar 2008 - 0:10

oui, c'est dans le .level, vérifie le fichier Wink

_________________
{Mes Vidéos} Config Pc:
Cpu : Amd Athlon 64 X2 4800+ Dual Core 2,50 GHz Cache L1 256 Ko L2 1 Mo Bus HT 2000 MHz
Ram : Corsair 3 Go XMS2 DDR2 800 MHz Pc 6400 (2x 512 Mo + 2x 1 Go)
Cg : Albatron nVidia GeForce 8600Gt Ram 512 Mo 400 MHz DDRII Gpu 540 MHz 128 Bits Shaders 1200 MHz - Pci-E

Sajuuk
Dévelopeur
Dévelopeur

Nombre de messages : 1479
Age : 21
Humeur : En forme!
Date d'inscription : 01/09/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par Elector le Dim 16 Mar 2008 - 0:45

D'accord je vais voir ça, on dirait que tu a fait plusieurs bug dans ton scriptage Sajuuk Razz

Elector
Dévelopeur
Dévelopeur

Nombre de messages : 232
Age : 24
Humeur : Pas de vos affaires!!
Date d'inscription : 27/01/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par Sajuuk le Dim 16 Mar 2008 - 3:01

j'ai pris au début le tuto de tommy, j'ai viré la plus part des trucs, mais j'ai fais un peu à l'arrache!

_________________
{Mes Vidéos} Config Pc:
Cpu : Amd Athlon 64 X2 4800+ Dual Core 2,50 GHz Cache L1 256 Ko L2 1 Mo Bus HT 2000 MHz
Ram : Corsair 3 Go XMS2 DDR2 800 MHz Pc 6400 (2x 512 Mo + 2x 1 Go)
Cg : Albatron nVidia GeForce 8600Gt Ram 512 Mo 400 MHz DDRII Gpu 540 MHz 128 Bits Shaders 1200 MHz - Pci-E

Sajuuk
Dévelopeur
Dévelopeur

Nombre de messages : 1479
Age : 21
Humeur : En forme!
Date d'inscription : 01/09/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par Elector le Dim 16 Mar 2008 - 4:27

lol j'ai vus ça...

non j'ai tout regarder mais rien ne corrige le probléme... jai même essayer abec un logiciel derelic rien...

Elector
Dévelopeur
Dévelopeur

Nombre de messages : 232
Age : 24
Humeur : Pas de vos affaires!!
Date d'inscription : 27/01/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par LeSunTzu le Dim 16 Mar 2008 - 12:06

Poste tes fichiers level et lua et on va debuguer tout ça

LeSunTzu
Dévelopeur
Dévelopeur

Nombre de messages : 149
Date d'inscription : 04/11/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par Elector le Dim 16 Mar 2008 - 18:58

Totorial.Campaign (marche parfaitement)
displayName = "Didacticiel"

Mission = {}

Mission[1] =
{
directory = "m01",
level = "m01.level",
postlevel = function ( bWin )

if bWin == 1 then

postLevelComplete()

end
end,
displayName = "Entrainement 1",
description = "Stargate Scenario",
}

Mission[2] =
{
directory = "m02",
level = "m02.level",
postlevel = function() postLevelComplete()
end,
displayName = "Entrainement 2 test",
description = "Stargate Scenario",
}

m01.lua (pas modifier)
dofilepath("data:scripts/scar/restrict.lua")
dofilepath("data:scripts/scar/scar_util.lua")
gs_gameOver = "ongoing"
gi_victoryLevel = 0
objectives = {}
objectives.obj_DestroyObject =
{
title = "Détruire le transporteur Goa'Uld.",
id = 0,
desc = "Construisez des bombardiers et détruisez le transporteur d'apophis.",
level = "primary", }
Events = {}
Events.ev_TacticalBriefing =
{
{
{ "Camera_UseCameraPoint('cam_Start')", "", },
},
{
HW2_Letterbox(1),
HW2_Wait(2),
{ "Sound_EnableAllSpeech(1)",""},
{ "Sound_EnterIntelEvent()","" },
{ "Universe_EnableSkip(1)", "" },
{ "Universe_AllowPlayerOrders(0)", "" },
{ "Camera_AllowControl(0)", "" },
{ "Sensors_EnableCameraZoom(0)", "" },
},
{
HW2_Pause(1),
},
{
HW2_Wait(1),
},
{
HW2_LocationCardEvent("Sortie de l'hyperespace.", 2),
},
{
HW2_Wait(0.5),
},
{
HW2_LocationCardEvent("Terre.", 2),
},
{
HW2_Wait(0.5),
},
{
HW2_SubTitleEvent(Actor_FleetIntel, "Carter: Nous devons être à déstination.", 2.5),
},
{
HW2_Wait(0.5),
},
{
{ "Sensors_Toggle(1)", "", },
},
{
HW2_Wait(0.5),
},
{
HW2_SubTitleEvent(Actor_FleetIntel, "Carter: Je détècte un vaisseau en approche!", 2.5),
},
{
HW2_Letterbox(0),
HW2_Wait(2),
HW2_Pause(0),
{ "Sound_ExitIntelEvent()","" },
{ "Sound_SetMuteActor(' ')", ""},
{ "Sensors_Toggle(0)", "", },
{ "Universe_AllowPlayerOrders( 1 )", "" },
{ "Camera_AllowControl( 1 )", "" },
{ "Sensors_EnableCameraZoom( 1 )", "" },
{ "Universe_EnableSkip(0)", "", },
},
}
Events.ev_Victory =
{
{
HW2_Letterbox(1),
HW2_Wait(2),
{ "Sound_EnableAllSpeech( 1 )",""},
{ "Sound_EnterIntelEvent()","" },
{ "Universe_EnableSkip( 0 )", "" },
{ "Universe_AllowPlayerOrders( 0 )", "" },
},
{
HW2_LocationCardEvent("Objectifs Atteints", 4),
},
{
{ "Universe_AllowPlayerOrders( 1 )", "" },
{ "setMissionComplete(1)", "" },
},
}
Events.ev_MarginalVictory =
{
{
HW2_Letterbox(1),
HW2_Wait(2),
{ "Sound_EnableAllSpeech( 1 )",""},
{ "Sound_EnterIntelEvent()","" },
{ "Universe_EnableSkip( 0 )", "" },
{ "Universe_AllowPlayerOrders( 0 )", "" },
},
{
HW2_LocationCardEvent("Mission Réussie", 4),
},
{
{ "Universe_AllowPlayerOrders( 1 )", "" },
{ "setMissionComplete(1)", "" },
},
}
Events.ev_LargeVictory =
{
{
HW2_Letterbox(1),
HW2_Wait(2),
{ "Sound_EnableAllSpeech( 1 )",""},
{ "Sound_EnterIntelEvent()","" },
{ "Universe_EnableSkip( 0 )", "" },
{ "Universe_AllowPlayerOrders( 0 )", "" },
},
{
HW2_LocationCardEvent("Mission Complétée", 4),
},
{
{ "Universe_AllowPlayerOrders( 1 )", "" },
{ "setMissionComplete(1)", "" },
},
}
Events.ev_Defeat =
{
{
HW2_Letterbox(1),
HW2_Wait(2),
{ "Sound_EnableAllSpeech(1)",""},
{ "Sound_EnterIntelEvent()","" },
{ "Universe_EnableSkip(0)", "" },
{ "Universe_AllowPlayerOrders(0)", "" },
},
{
HW2_LocationCardEvent("Mission Annulée", 4),
},
{
{ "Universe_AllowPlayerOrders(1)", "" },
{ "setMissionComplete(0)", "" },
},
}
Events.ev_LargeDefeat =
{
{
HW2_Letterbox(1),
HW2_Wait(2),
{ "Sound_EnableAllSpeech( 1 )",""},
{ "Sound_EnterIntelEvent()","" },
{ "Universe_EnableSkip( 0 )", "" },
{ "Universe_AllowPlayerOrders( 0 )", "" },
},
{
HW2_LocationCardEvent("Mission Echouée", 4),
},
{
{ "Universe_AllowPlayerOrders( 1 )", "" },
{ "setMissionComplete(0)", "" },
},
}
Events.ev_DestroyObject =
{
{
{ "Camera_FocusSobGroupWithBuffer('sg_TargetObject', 2000, 2000, 4)", "" },
},
{
HW2_SubTitleEvent(Actor_FleetIntel, "Nous détectons un transporteur Gao'Uld.", 2),
},
{
HW2_Wait(1),
},
{
{ "png_TargetObject = Ping_AddSobGroup('Transporteur', 'anomaly', 'sg_TargetObject')", "", },
{ "Ping_AddDescription(png_TargetObject, 0, 'Transporteur' )", "", },
},
}
Events.ev_ObjectIsDestroyed =
{
{
{ "Ping_Remove('png_TargetObject')", "", },
},
{
HW2_SubTitleEvent(Actor_FleetIntel, "Target Destroyed", 2),
},
{
HW2_Wait(1),
},
}
function Rule_InitMission1()
Player_Kill(2)
SobGroup_Despawn("Transporteur")
Event_Start("ev_TacticalBriefing")
Rule_Add("Rule_DestroyObject")
Rule_AddInterval("Rule_WatchObjectives", 3)
Rule_Remove("Rule_InitMission1")
end
function Player_Setup()
Player_SetTeamColours(0, {109/255, 164/255, 217/255}, {219/255, 223/255, 163/255})
Player_SetBadgeTexture(0, "DATA:badges/KIITH SJET.tga")
end
function AI_Setup()
SetAlliance(1, 2)
Player_SetTeamColours(1, {30/255, 30/255, 30/255}, {225/255, 225/255, 225/255})
Player_SetBadgeTexture(1, "DATA:badges/VAYGR.TGA")
Player_SetPlayerName(1, "Apophis")
Player_SetDefaultShipTactic(1, AggressiveTactics)
end
function Rule_DestroyObject()
if Event_IsDone("ev_TacticalBriefing") == 1 then -- it's advisable to start the first objective only after the first event is done
SobGroup_Create("sg_TargetObject")
Player_FillShipsByType("sg_TargetObject", 1, "goa_carrier") -- define target here
addObjective("obj_DestroyObject")
Event_Start("ev_DestroyObject")
Rule_AddInterval("Rule_WatchObjectDestroyed", 5)
Rule_Remove("Rule_DestroyObject")
end
end
function Rule_WatchObjectDestroyed()
local li_testflag = 0
if SobGroup_Empty("sg_TargetObject") == 1 then
li_testflag = 1
elseif SobGroup_AreAnyFromTheseAttackFamilies("Player_Ships0", "Fighter") == 0 then -- can be deleted
li_testflag = 2 -- can be deleted
end
if li_testflag == 1 then
Event_Start("ev_ObjectIsDestroyed")
completeObjective("obj_DestroyObject")
Rule_Remove("Rule_WatchObjectDestroyed")
elseif li_testflag == 2 then
failedObjective("obj_DestroyObject")
Rule_Remove("Rule_WatchObjectDestroyed")
end
end
function Rule_WatchObjectives()
if Event_IsDone("ev_TacticalBriefing") == 1 then -- always wait for the objectives to be set
gs_gameOver = "victory"
for i, iCount in objectives do -- watches primaries to end game
if iCount.level == "primary" then
if Objective_GetState(iCount.id) == OS_Incomplete then
gs_gameOver = "ongoing"
end
end
end
for i, iCount in objectives do -- watches primaries to end game
if iCount.level == "primary" then
if Objective_GetState(iCount.id) == OS_Failed then
gs_gameOver = "defeat"
end
end
end
if HW2_PlayerHasMilitary(0) == 0 then -- always end when player has no military ship left
gs_gameOver = "defeat"
end
if gs_gameOver ~= "ongoing" then
Rule_AddInterval("Rule_GameEnds", 5) -- set sufficient interval for all secondaries to be assessed before actual end
Rule_Remove("Rule_WatchObjectives")
end
end
end
function Rule_GameEnds()
for i, iCount in objectives do -- evaluates secondaries to determine the victory level
if iCount.id ~= 0 and iCount.level == "primary" then
if Objective_GetState(iCount.id) == OS_Failed then
gi_victoryLevel = gi_victoryLevel - 1
elseif Objective_GetState(iCount.id) == OS_Complete then
gi_victoryLevel = gi_victoryLevel + 1
end
end
end
if gs_gameOver == "victory" and gi_victoryLevel == 0 then
Event_Start("ev_Victory")
elseif gs_gameOver == "victory" and gi_victoryLevel < 0 then
Event_Start("ev_MarginalVictory")
elseif gs_gameOver == "victory" and gi_victoryLevel > 0 then
Event_Start("ev_LargeVictory")
elseif gs_gameOver == "defeat" and gi_victoryLevel < 0 then
Event_Start("ev_LargeDefeat")
elseif gs_gameOver == "defeat" and gi_victoryLevel >= 0 then
Event_Start("ev_Defeat")
end
end
function completeObjective(obj)
Objective_SetState(objectives[obj].id, OS_Complete)
end

function failedObjective(obj)
Objective_SetState(objectives[obj].id, OS_Failed)
end

function ignoreObjective(obj)
Objective_SetState(objectives[obj].id, OS_Off)
end

Elector
Dévelopeur
Dévelopeur

Nombre de messages : 232
Age : 24
Humeur : Pas de vos affaires!!
Date d'inscription : 27/01/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par Elector le Dim 16 Mar 2008 - 18:58

m01.level (fait avec MissionBoySE)
-- Guillaume
--
-- Generated by Mission Boy SE v1.9
-- Mission Boy by IWAssassin
-- MissionBoySE by Delphy, May 2004
-- Author: Elector
levelDesc = "Stargate Scenario"
maxPlayers = 2

player = {}

player[0] = {
id = 0,
name = "Tauri",
resources = 0,
raceID = 1,
startPos = 0,
}

player[1] = {
id = 1,
name = "Goauld",
resources = 0,
raceID = 2,
startPos = 0,
}

function DetermChunk()
addPoint("PlayerStartPoint", {-455, 0, -27491}, {0, 0, 0})
addAsteroid("Asteroid_6", {3484, 0, -22928}, 600, 0, 0, 0, 0)
addAsteroid("Asteroid_6", {3030, 0, -20875}, 600, 0, 0, 0, 0)
addAsteroid("Asteroid_6", {3939, 0, -19962}, 600, 0, 0, 0, 0)
addAsteroid("Asteroid_6", {4848, 0, -22244}, 600, 0, 0, 0, 0)
addDustCloud("polySurface1", "dustcloud_0", {-8334, 0, -21788}, {0, 1, 1, 1}, 0.0, 100)
addDustCloud("polySurface1", "dustcloud_0", {10757, 0, -10153}, {0, 1, 1, 1}, 0.0, 100)
addNebula("m05_dustcloud_nebula", "m05_dustcloud_nebula", {-11667, 0, 114}, {0,501960784313725, 0,501960784313725, 1, 1}, 0.0, 200)
createSOBGroup("Transport")
addSquadron("tau_x302", "tau_x302", {-1819, 0, -24069}, 0, {0, 0, 0}, 0, 0)
addSquadron("tau_x302", "tau_x302", {-910, 0, -23841}, 0, {0, 0, 0}, 0, 0)
addSquadron("tau_x302", "tau_x302", {0, 0, -23841}, 0, {0, 0, 0}, 0, 0)
addSquadron("tau_x302", "tau_x302", {757, 0, -23841}, 0, {0, 0, 0}, 0, 0)
addSquadron("tau_f302", "tau_f302", {-1516, 0, -23385}, 0, {0, 0, 0}, 0, 0)
addSquadron("tau_f302", "tau_f302", {-758, 0, -23385}, 0, {0, 0, 0}, 0, 0)
addSquadron("tau_f302", "tau_f302", {0, 0, -22928}, 0, {0, 0, 0}, 0, 0)
addSquadron("goa_carrier", "goa_carrier", {-455, 0, -6274}, 1, {0, 0, 0}, 0, 0)
addToSOBGroup("goa_carrier", "Transport")
addSquadron("goa_glider", "goa_glider", {-1667, 0, -7415}, 1, {0, 0, 0}, 0, 0)
addSquadron("goa_glider", "goa_glider", {303, 0, -7187}, 1, {0, 0, 0}, 0, 0)
addSquadron("goa_threader", "goa_threader", {-1364, 0, -5590}, 1, {0, 0, 0}, 0, 0)
addSquadron("goa_threader", "goa_threader", {303, 0, -5818}, 1, {0, 0, 0}, 0, 0)
setWorldBoundsInner({0, 0, 0}, {30000, 20000, 30000})
addCamera("cam_Start", { 6227, 1120, 270, }, { 6636, 1264, 479, })
addSphere("vol_FleeSphere", { 500, 1600, 6000, }, 225)
end

function NonDetermChunk()
fogSetActive(0)
setGlareIntensity(0)
setLevelShadowColour(0, 0, 0, 1)
loadBackground("m01")
setSensorsManagerCameraDistances(5000, 230000)
setDefaultMusic("Data:sound/music/Ambient/amb_02")
setDustCloudAmbient({ 0.5, 0.5, 0.5, 1, })
end

Elector
Dévelopeur
Dévelopeur

Nombre de messages : 232
Age : 24
Humeur : Pas de vos affaires!!
Date d'inscription : 27/01/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par Sajuuk le Dim 16 Mar 2008 - 20:52

ça marche ?

_________________
{Mes Vidéos} Config Pc:
Cpu : Amd Athlon 64 X2 4800+ Dual Core 2,50 GHz Cache L1 256 Ko L2 1 Mo Bus HT 2000 MHz
Ram : Corsair 3 Go XMS2 DDR2 800 MHz Pc 6400 (2x 512 Mo + 2x 1 Go)
Cg : Albatron nVidia GeForce 8600Gt Ram 512 Mo 400 MHz DDRII Gpu 540 MHz 128 Bits Shaders 1200 MHz - Pci-E

Sajuuk
Dévelopeur
Dévelopeur

Nombre de messages : 1479
Age : 21
Humeur : En forme!
Date d'inscription : 01/09/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par Elector le Dim 16 Mar 2008 - 21:10

Oui sauf que sa bug a load level

Elector
Dévelopeur
Dévelopeur

Nombre de messages : 232
Age : 24
Humeur : Pas de vos affaires!!
Date d'inscription : 27/01/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par Sajuuk le Dim 16 Mar 2008 - 21:23

donc, ça marche pas

_________________
{Mes Vidéos} Config Pc:
Cpu : Amd Athlon 64 X2 4800+ Dual Core 2,50 GHz Cache L1 256 Ko L2 1 Mo Bus HT 2000 MHz
Ram : Corsair 3 Go XMS2 DDR2 800 MHz Pc 6400 (2x 512 Mo + 2x 1 Go)
Cg : Albatron nVidia GeForce 8600Gt Ram 512 Mo 400 MHz DDRII Gpu 540 MHz 128 Bits Shaders 1200 MHz - Pci-E

Sajuuk
Dévelopeur
Dévelopeur

Nombre de messages : 1479
Age : 21
Humeur : En forme!
Date d'inscription : 01/09/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par LeSunTzu le Dim 16 Mar 2008 - 22:20

Bon alors dans l'ordre :

1. Crée dans le fichier scripts/unitcaps un fichier singleplayer.lua. Sinon HW2 prend celui d'origine, chercher les Vaygr et plante.

2. Dans le fichier level, utilise des asteroids qui existent (pas d'asteroid_6 !). C'est ça qui plante sans message dans l'error log.

3. Dans le fichier level, n'oublie jamais que HW2 est en anglais, donc la décimale c'est le point. Tu as mis quelques virgules à la place des points dans addNebula, alors le programme croit qu'il y a trop d'arguments dans la fonction et plante.

4. Dans le fichier lua, il faut absolument la fonction OnInit. Sinon HW2 plante. Au minimum c'est:
function OnInit()
end
(fonction vide)

C'est la fonction qui lance le script, donc c'est là que tu appelles les autres fonctions.

Voilou !

LeSunTzu
Dévelopeur
Dévelopeur

Nombre de messages : 149
Date d'inscription : 04/11/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par Sajuuk le Dim 16 Mar 2008 - 22:25

merci! je vais essayer tout ça!

_________________
{Mes Vidéos} Config Pc:
Cpu : Amd Athlon 64 X2 4800+ Dual Core 2,50 GHz Cache L1 256 Ko L2 1 Mo Bus HT 2000 MHz
Ram : Corsair 3 Go XMS2 DDR2 800 MHz Pc 6400 (2x 512 Mo + 2x 1 Go)
Cg : Albatron nVidia GeForce 8600Gt Ram 512 Mo 400 MHz DDRII Gpu 540 MHz 128 Bits Shaders 1200 MHz - Pci-E

Sajuuk
Dévelopeur
Dévelopeur

Nombre de messages : 1479
Age : 21
Humeur : En forme!
Date d'inscription : 01/09/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par Elector le Dim 16 Mar 2008 - 23:33

singleplayer deja fait
je le met oèu le function OnInit()
end

Elector
Dévelopeur
Dévelopeur

Nombre de messages : 232
Age : 24
Humeur : Pas de vos affaires!!
Date d'inscription : 27/01/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par LeSunTzu le Lun 17 Mar 2008 - 0:39

N'importe où (sauf dans une autre fonction ou un tableau) dans m01.lua.

LeSunTzu
Dévelopeur
Dévelopeur

Nombre de messages : 149
Date d'inscription : 04/11/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par Elector le Lun 17 Mar 2008 - 1:02

Super sa marche... le seul probléme :
il n'y a rien qui se passe... sa doit être la place ou j,ai mis ton truc

Elector
Dévelopeur
Dévelopeur

Nombre de messages : 232
Age : 24
Humeur : Pas de vos affaires!!
Date d'inscription : 27/01/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par LeSunTzu le Lun 17 Mar 2008 - 1:15

Comme j'ai dit plus haut, c'est OnInit qui lance le script. C'est là que tu appelles les autres fonctions et/ou les "events". Tout ça dépend de ce que tu veux faire.

Dans le temps j'avais fait des canevas de mission. Si tu te débrouilles en anglais tu peux jeter un oeil sur ça http://files.filefront.com/Template+SP+Scriptrar/;4621813;/fileinfo.html pour voir comment ça marche.

LeSunTzu
Dévelopeur
Dévelopeur

Nombre de messages : 149
Date d'inscription : 04/11/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Etrange bug

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum