I A O_o

Voir le sujet précédent Voir le sujet suivant Aller en bas

I A O_o

Message par Sajuuk le Dim 6 Avr 2008 - 22:58

Salut! j'ai trouvé comment faire l'ia, je l'ai finie mais pas l'ia avec les recherches, par contre quand je lance la partie, il me dit ça :
stack traceback:
1: function `oninit' at line 32 [string ""]
CPUPLAYER -- error in CPUPlayer: oninit() function was not found in CPU script -- FATAL EXIT --
Il n'y a aucun fichier cpuplayer, a quel fichier fait il référence ?

_________________
{Mes Vidéos} Config Pc:
Cpu : Amd Athlon 64 X2 4800+ Dual Core 2,50 GHz Cache L1 256 Ko L2 1 Mo Bus HT 2000 MHz
Ram : Corsair 3 Go XMS2 DDR2 800 MHz Pc 6400 (2x 512 Mo + 2x 1 Go)
Cg : Albatron nVidia GeForce 8600Gt Ram 512 Mo 400 MHz DDRII Gpu 540 MHz 128 Bits Shaders 1200 MHz - Pci-E
avatar
Sajuuk
Dévelopeur
Dévelopeur

Nombre de messages : 1479
Age : 22
Humeur : En forme!
Date d'inscription : 01/09/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: I A O_o

Message par LeSunTzu le Dim 6 Avr 2008 - 23:32

Je crois que c'est l'erreur classique du cpubuild.lua mal décompilé.
avatar
LeSunTzu
Dévelopeur
Dévelopeur

Nombre de messages : 149
Date d'inscription : 04/11/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: I A O_o

Message par Elector le Lun 7 Avr 2008 - 0:27

CPUplayer est la ligne, c'est un script cpu je crois
avatar
Elector
Dévelopeur
Dévelopeur

Nombre de messages : 232
Age : 25
Humeur : Pas de vos affaires!!
Date d'inscription : 27/01/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: I A O_o

Message par Sajuuk le Lun 7 Avr 2008 - 18:09

quelqu'un peut m'aider ?

_________________
{Mes Vidéos} Config Pc:
Cpu : Amd Athlon 64 X2 4800+ Dual Core 2,50 GHz Cache L1 256 Ko L2 1 Mo Bus HT 2000 MHz
Ram : Corsair 3 Go XMS2 DDR2 800 MHz Pc 6400 (2x 512 Mo + 2x 1 Go)
Cg : Albatron nVidia GeForce 8600Gt Ram 512 Mo 400 MHz DDRII Gpu 540 MHz 128 Bits Shaders 1200 MHz - Pci-E
avatar
Sajuuk
Dévelopeur
Dévelopeur

Nombre de messages : 1479
Age : 22
Humeur : En forme!
Date d'inscription : 01/09/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: I A O_o

Message par Orion le Lun 7 Avr 2008 - 19:56

C'est bien Sajuuk ne te décourage pas.
avatar
Orion
Dévelopeur
Dévelopeur

Nombre de messages : 333
Date d'inscription : 01/09/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: I A O_o

Message par Sajuuk le Lun 7 Avr 2008 - 20:43

parceque j'ai cherché dans cpubuild et y a pas de oninit, même dans celui de l'ancien mod!

_________________
{Mes Vidéos} Config Pc:
Cpu : Amd Athlon 64 X2 4800+ Dual Core 2,50 GHz Cache L1 256 Ko L2 1 Mo Bus HT 2000 MHz
Ram : Corsair 3 Go XMS2 DDR2 800 MHz Pc 6400 (2x 512 Mo + 2x 1 Go)
Cg : Albatron nVidia GeForce 8600Gt Ram 512 Mo 400 MHz DDRII Gpu 540 MHz 128 Bits Shaders 1200 MHz - Pci-E
avatar
Sajuuk
Dévelopeur
Dévelopeur

Nombre de messages : 1479
Age : 22
Humeur : En forme!
Date d'inscription : 01/09/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: I A O_o

Message par LeSunTzu le Lun 7 Avr 2008 - 21:08

Je crois bien que pour chaque IA, HW2 fait tourner tous les scripts en un. L'erreur que tu as est classique quand on bidouille les fichiers IA. Est-ce que par hasard tu n'aurais pas une autre erreur mentionnée avant celle-là dans ton log ?
avatar
LeSunTzu
Dévelopeur
Dévelopeur

Nombre de messages : 149
Date d'inscription : 04/11/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: I A O_o

Message par Sajuuk le Lun 7 Avr 2008 - 21:33

je crois oui:
Starting Level: data:LevelData\Multiplayer\deathmatch\TRAININGGROUNDS.LEVEL
EngineTrailStatic::getTweaks requesing index(2) that doesn't exist.
EngineTrailStatic::getTweaks requesing index(2) that doesn't exist.
EngineTrailStatic::getTweaks requesing index(2) that doesn't exist.
parameter: expected;
last token read: `,' at line 26 in string ""
stack traceback:
1: function `dofilepath' [C]
2: main of string "" at line 3
parameter: expected;
last token read: `local' at line 378 in string ""
stack traceback:
1: function `dofilepath' [C]
2: main of string "" at line 4
parameter: attempt to call global `ClassInitialize' (a nil value)
stack traceback:
1: function `oninit' at line 32 [string ""]
CPUPLAYER -- error in CPUPlayer: oninit() function was not found in CPU script -- FATAL EXIT -- hw2cpuplayer/180:! --stack trace-- 0x004CF47B: GSLobbySessionDesc::operator= () 0x004938A4: GSLobbySessionDesc::operator= () 0x00495390: GSLobbySessionDesc::operator= () 0x004952A1: GSLobbySessionDesc::operator= () 0x00490C11: GSLobbySessionDesc::operator= () 0x004911D2: GSLobbySessionDesc::operator= ()

_________________
{Mes Vidéos} Config Pc:
Cpu : Amd Athlon 64 X2 4800+ Dual Core 2,50 GHz Cache L1 256 Ko L2 1 Mo Bus HT 2000 MHz
Ram : Corsair 3 Go XMS2 DDR2 800 MHz Pc 6400 (2x 512 Mo + 2x 1 Go)
Cg : Albatron nVidia GeForce 8600Gt Ram 512 Mo 400 MHz DDRII Gpu 540 MHz 128 Bits Shaders 1200 MHz - Pci-E
avatar
Sajuuk
Dévelopeur
Dévelopeur

Nombre de messages : 1479
Age : 22
Humeur : En forme!
Date d'inscription : 01/09/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: I A O_o

Message par LeSunTzu le Mar 8 Avr 2008 - 0:23

Difficile à dire sans le fichier, mais tu peux déjà vérifier si tu n'as pas fait de typo dans classdef.lua.

Le log indique que la fonction ClassInitialize n'a pas été déclarée, donc il est possible que tu n'ais pas refermé une accolade ou des crochets (ou laissé une virgule en fin de ligne) en remplissant le tableau squadclass.

Pour info: quand lua ne comprend pas un bloc d'instructions, il le zappe. Ici le bloc oninit est zappé car il ne trouve pas ClassInitialize. Du coup HW2 ne retrouve pas oninit et ça c'est une erreur fatale avec crash sur le bureau. C'est pour ça que le log se termine en disant qu'il ne trouve pas oninit.
avatar
LeSunTzu
Dévelopeur
Dévelopeur

Nombre de messages : 149
Date d'inscription : 04/11/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: I A O_o

Message par Sajuuk le Mar 8 Avr 2008 - 22:22

ok mci!

_________________
{Mes Vidéos} Config Pc:
Cpu : Amd Athlon 64 X2 4800+ Dual Core 2,50 GHz Cache L1 256 Ko L2 1 Mo Bus HT 2000 MHz
Ram : Corsair 3 Go XMS2 DDR2 800 MHz Pc 6400 (2x 512 Mo + 2x 1 Go)
Cg : Albatron nVidia GeForce 8600Gt Ram 512 Mo 400 MHz DDRII Gpu 540 MHz 128 Bits Shaders 1200 MHz - Pci-E
avatar
Sajuuk
Dévelopeur
Dévelopeur

Nombre de messages : 1479
Age : 22
Humeur : En forme!
Date d'inscription : 01/09/2007

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: I A O_o

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum